티스토리 뷰

iOS 5.1 버전으로 업글되면서 xcode 4.2에서는 해당 버전 빌드가 안됩니다.

조금 노가다를 하시면됩니다.


해결방안.

http://stackoverflow.com/questions/9614918/xcode-4-2-snow-leopard-and-ios-5-1

위에 링크 따라가면 Richard Groves분이 해결방안을 올려놓았습니다.

설명을 드리면.

일단 Xcode 4.3버전을 다운로드. 링크는 아래.


저는 링크에서 Xcode 4.3.1 for Lion 버전을 다운로드하였습니다.(개발자 계정은 다들 가지고 계시죠...?)

 
다운로드 완류 후 아래와 같이 순서대로 하시면되요.

1. Contents/Developer/Platforms/iPhoneOS.platform/Developer/SDKs/iPhoneOS5.1.sdk

--> /Developer/Platforms/iPhoneOS.platform/Developer/SDKs/ 폴더로 복사

2. Contents/Developer/Platforms/iPhoneOS.platform/Developer/DeviceSupport/5.1 (9B176)

--> /Developer/Platforms/iPhoneOS.platform/Developer/DeviceSupport/ 폴더로 복사

3. Contents/Developer/Platforms/iPhoneOS.platform/version.plist

--> /Developer/Platforms/iPhoneOS.platform 폴더로 복사 
(복사하기 전에 version.plist를 version.plist.org로 백업을 먼저 하세요)

4. Contents/Developer/Platforms/iPhoneSimulator.platform/Developer/SDKs/iPhoneSimulator5.1.sdk

-> /Developer/Platforms/iPhoneSimulator.platform/Developer/SDKs/ 폴더로 복사



설마 혹시 모르실까봐 "패키지 내용 보기" 스샷 찍어놓습니다.(우클릭후 "패키지 내용 보기" 선택후 위에 빨간글씨 순서대로하세요.)




출처 : 맥부기 사비성님글 
http://cafe.naver.com/mcbugi.cafe?iframe_url=/ArticleRead.nhn%3Farticleid=198969&


댓글
  • 프로필사진 아어씨...진짜... 아씨 정말 너무 감사요 ㅠㅠ
    상사가 개발폰 가져가서 업뎃 해버려서 4.2 에서 판올림 해야되나 막막했는데 완전 빛과 같은 희망을 주셨습니다. ㅠㅠ
    2012.05.10 10:58
  • 프로필사진 Favicon of https://88oy.tistory.com 팔팔청춘 저도 퍼온것이지만
    도움되셧다니 다행이네요^^
    2012.05.18 09:57 신고
댓글쓰기 폼
공지사항
Total
741,539
Today
136
Yesterday
151
«   2019/08   »
        1 2 3
4 5 6 7 8 9 10
11 12 13 14 15 16 17
18 19 20 21 22 23 24
25 26 27 28 29 30 31
글 보관함